Author [ES] [CA] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: Quickshifter not working  (Read 291 times)

0 Members and 1 Guest are viewing this topic.

Offline adammg

  • S1000R Junior
  • *
  • Posts: 6
  • Country: england
  • Bike: BMW S1000R sport
  • City / Town: WAKEFIELD
Quickshifter not working
« on: May 19, 2020, 04:20:03 PM »
Hi I bought I 2015 s1000r sport back in February, I noticed at the time it must have been previously damaged as the near side fairing had been painted. I did not test ride the bike at the time as it was pissing it down. as I desperately wanted a s1000r I paid the guy put it in my van and drove away.

Fast forward a couple of months and the first ride is here, love the bike but quickshifter is not working.
on inspection I found the little toggle that pushes the micro swtich in on the clutch lever is missing. Bought a new one from BMW (66!) fitted it and still not working! Decided the microswitch must be damaged, rang BMW for the part, (had a double micro switch fitted) they sold me  single micro switch saying that mine had the wrong one fitted and a single was for bikes without cruise control.
So I fitted the new single microswitch, appears to be all in order, and the quickshifter still does not work. Does  anyone have any suggestions as to where I go from here?

thanks adam

Offline SimonUK

  • S1000R Grand Master
  • *****
  • Posts: 3343
  • Country: us
  • Bike: S1000XR, S1000R
  • City / Town: Upstate SC
Re: Quickshifter not working
« Reply #1 on: May 19, 2020, 04:39:31 PM »
Did your bike come with a manual? if so, then look up how to 're-learn' the QS. You should also be able to download the Rider/owner manual - http://mybikemanuals.com/bmw/2015-bmw-owners-manuals/

Offline beech

  • S1000R Master
  • ****
  • Posts: 592
  • Country: us
  • I change tires, you buy them on the web. $50
  • Bike: S1000R, K1300S
  • City / Town: Mount Vernon, WA
Re: Quickshifter not working
« Reply #2 on: May 20, 2020, 05:59:00 AM »
The relearning process is to run the bike in each gear from 1N23456 for about ten seconds each. The DVD says you can do this with out starting the bike (key on of course). I have done this. Try it first. Others say the bike has to be running and on the road. I suggest if you have a rear paddock stand to lift the bike and give it a go. I did this with a GS911 computer reader tool. thinking to myself why did the shop not help you with this?

Offline adammg

  • S1000R Junior
  • *
  • Posts: 6
  • Country: england
  • Bike: BMW S1000R sport
  • City / Town: WAKEFIELD
Re: Quickshifter not working
« Reply #3 on: May 20, 2020, 08:58:02 AM »
I just ordered the parts and fitted them presuming this would rectify the shifter not working. Thanks for the reply I'll give it a go this morning

Offline adammg

  • S1000R Junior
  • *
  • Posts: 6
  • Country: england
  • Bike: BMW S1000R sport
  • City / Town: WAKEFIELD
Re: Quickshifter not working
« Reply #4 on: May 20, 2020, 02:00:23 PM »
Just been out on the road trying to re learn the shifter, still not working. Just seen you put 1N23456, do you by pass neutral or leave it in neutral for 10 seconds then 2nd?

Offline NuTTs

  • S1000R Member
  • **
  • Posts: 37
  • Country: es
  • Bike: BMW S1000R
  • City / Town: Madrid
Re: Quickshifter not working
« Reply #5 on: May 20, 2020, 04:06:37 PM »
*Originally Posted by adammg [+]
Hi I bought I 2015 s1000r sport back in February, I noticed at the time it must have been previously damaged as the near side fairing had been painted. I did not test ride the bike at the time as it was pissing it down. as I desperately wanted a s1000r I paid the guy put it in my van and drove away.

Fast forward a couple of months and the first ride is here, love the bike but quickshifter is not working.
on inspection I found the little toggle that pushes the micro swtich in on the clutch lever is missing. Bought a new one from BMW (66!) fitted it and still not working! Decided the microswitch must be damaged, rang BMW for the part, (had a double micro switch fitted) they sold me  single micro switch saying that mine had the wrong one fitted and a single was for bikes without cruise control.
So I fitted the new single microswitch, appears to be all in order, and the quickshifter still does not work. Does  anyone have any suggestions as to where I go from here?

thanks adam

Do you happen to have the part number for this or the one for both the QS and Cruise Control?

Mine's just died again, only Cruise Control works.
Shenanigans Inc.

Offline adammg

  • S1000R Junior
  • *
  • Posts: 6
  • Country: england
  • Bike: BMW S1000R sport
  • City / Town: WAKEFIELD
Re: Quickshifter not working
« Reply #6 on: May 20, 2020, 07:17:16 PM »
No, sorry. I just rang the dealer and they posted me one out. 33+ vat for the new switch

 


Recent Posts/Topics